TECH SUPPORT

SQL-RD Pre-Requisites

Follow

ALL of the following pre-requisites must be met in order to successfully install and use SQL-RD. If ANY of the following requirements are not met, some or all of SQL-RD's functionalities will not work as designed.

 

Operating System - Main

Please ensure at least ONE of the following 32 or 64-bit Operating Systems are in place with all the latest service packs and/or updates installed.

  • Windows Server 2008
  • Windows Server 2008 R2
  • Windows 7
  • Windows 8
  • Windows 10
  • Windows Server 2012
  • Windows Server 2012 R2
  • Windows Server 2016

 

Operating System - Additional

Please ensure ALL of the following are in place:

  • User Account Control (UAC) is turned off
  • Anti-virus and other security is turned off
  • Primary Drive Disk Space
    • Minimum: 20 GB
    • Recommended: 200 GB
  • Installed Memory/RAM
    • Minimum: 4 GB
    • Recommended: 8 GB

 

Note: UAC and Anti-Virus only need to be turned off during the SQL-RD installation process. They may be turned back on once the installation process is complete.

Note: Disk Space and Memory/RAM requirements will vary based on report outputs. However, you will need to have at least 1 GB of free disk space on your primary drive for SQL-RD to install properly, even if you will be installing SQL-RD on a secondary drive. Most disk space used during the installation process will be returned after first use of the software.

 

Microsoft Office

If you will use extended Output functions (e.g. Email, Excel Bursting, Merging, Document Properties, etc.), please ensure that ONE of the following is in place with all of the latest service packs and/or updates installed:

  • Outlook/Excel/Office 2003 32 Bit Version Only
  • Outlook/Excel/Office 2007 32 Bit Version Only
  • Outlook/Excel/Office 2010 32 Bit Version Only
  • Outlook/Excel/Office 2013 32 Bit Version Only
  • Outlook/Excel/Office 2016 32 Bit Version Only
  • Outlook/Excel/Office 365

 

Microsoft Exchange

If you use Exchange to process email, please ensure that ONE of the following is in place with all the latest service packs and/or updates installed:

  • Any version of Exchange released after October 2003 (Exchange 2003, Exchange 2007, Exchange 2010, etc.)

 

Note: Integration with other versions of Exchange may work even if the latest service packs are not installed, but some functionality may error or be unavailable. For best results, please ensure you have applied the latest service pack and all updates.

 

SMTP Server

If you use SMTP to process email, please ensure that ALL of the following are in place:

  • You must know your mailbox security credentials.
  • Your server must allow relaying.

 

Note: If you do not know your mailbox security credentials or are unsure if your server allows relaying, please contact your Email Administrator.

 

Windows (NT) Service Scheduler

SQL-RD installs a background application scheduler by default. However, if you wish to use the Windows (NT) Service Scheduler, you can do so by going to Options Scheduling and clicking the radio button next to Use NT Service.

Prior to using the NT Service Scheduler, you must ensure ALL of the of the following:

  • The Windows Service user has full security rights to the mailbox to be used (if you will be emailing the reports).
  • The above user has full security rights to network files and folders (if you are reading reports across the network and if you are exporting to network folders).
  • The above user has full security rights to any FTP location you may be exporting to.
  • The above user has Log on as a service rights on the local PC.
  • The above user has Act as part of the operating system rights on the local PC.
  • The above user is a local administrator (or a member of the local administrator group) of the PC.

 

Note: If you need assistance with any of the pre-requisites listed above, please contact your system administrator.

 

SSRS & SQL Server Compatibility

SQL-RD will export and distribute reports served by various versions of SSRS. Please ensure that you are running at least ONE of the following versions:

  • Reporting Services 2005
  • Reporting Services 2008
  • Reporting Services 2008 R2
  • Reporting Services 2012
  • Reporting Services 2016

 

SQL-RD can be used to interface with various versions of SQL Server. Please ensure you are using at least ONE of the following versions:

  • SQL Server 2005
  • SQL Server 2008
  • SQL Server 2008 R2
  • SQL Server 2012
  • SQL Server 2014
  • SQL Server 2016

 

Note: If you use the default local SQL Server instance that the SQL-RD installer creates, the database will install using the free SQL Server 2008 R2 Express edition.

 

Additional Information

You can use SQL-RD to interface with, and manage, multiple instances of SSRS reports. Simply point the application to the server's URL to connect to the reports that are stored on that server. This makes SQL-RD an important tool for managing multiple SSRS installations (local and remote) from a single application interface. You can even mix and match different version of SSRS. 

For Example: Report 1 come from an SSRS 2005 installation, but Report 2 comes from an SSRS 2008 R2 installation, and so on.

Comments